OS・アプリ

続:PHPな備忘録

el5 で,普通に yum install php ほにゃらら みたいにすると PHP 5.1.6-**  なんて,古いのが入ってしまいます。このままでは何かと不便なので,PHP 5.1.6 をアンインストール後,yum install php53 ほにゃららで,アップグレード。

セキュリティ的には,最新のものを入れた方が良いのですけど,http サービスは止めてるし,内部的なコマンドとしてしか使用しないのでとりあえずOK

で,コマンドを実行したら Warning: strtotime() が出るようになってしまいました。

エラーメッセージを見ると...
It is not safe to rely on the system’s timezone settings. You are *required* to use the date.timezone setting or the date_default_timezone_set() function. <以下略>

どうやら,timezone を設定しろと,指導を受けているようです。
php.ini を覗くと

[Date]
; Defines the default timezone used by the date functions
; http://www.php.net/manual/en/datetime.configuration.php#ini.date.timezone
;date.timezone =

の項目があるので

date.timezone = 'Asia/Tokyo'

として,万事解決


コメントを残す